User supplied callback function for handling backward conversion on user data attached to elements
typedef GSErrCode APIElemSetSaveOldFormatHandlerProc ( API_FTypeID planFileType, const GSPtr dataPtr, GSPtr* oldDataPtr );
Parameters
- planFileType
- [in] File type’s ID of the save process
- dataPtr
- [in] Pointer to the attached user data
- oldDataPtr
- [out] Pointer to the backward converted user data
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
oldDataPtr is nullptr on call, and should be allocated in the function. If it is nullptr on return, the used data will be deleted from the saved plan.
Requirements
- Version: API 20 or later
- Header: APIdefs_Callback.h