APIEnv_​AddLibrariesID

Registers a new folder into the list of active libraries.

    GSErrCode ACAPI_Environment (
        APIEnv_AddLibrariesID,
        IO::Location*     newLib
    );

 

Parameters

newLib
[in] The file system location of the folder to add.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
newLib is nullptr.
APIERR_NOTMINE
The project library list is not editable in Teamwork. You need to reserve it first.

For other common API errors see the API Errors document.

 

Remarks

The registered folder will be the default one, which means that Library Parts created by the subsequent ACAPI_LibPart_Create functions automatically will go into this library, unless an other folder is specified.

The modified list of active libraries will be enumerated.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

Note that BIM Server libraries cannot be added to the project with this function.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetLibrariesID, APIEnv_SetLibrariesID, APIEnv_ResetLibrariesID,
ACAPI_Environment, API Functions