Returns information about the current application.
GSErrCode ACAPI_Environment ( APIEnv_ApplicationID, API_ServerApplicationInfo* serverApplicationInfo );
Parameters
- serverApplicationInfo
- [out] Information about the server application. Contains the main and maintenance release number of the server application.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- the
serverInfo
isnullptr
.
For other common API errors see the API Errors document.
Remarks
This function is used to get that the add-on is currently running in Archicad or the 3D Engine.
The returned serverInfo->serverApplication
value can be:
APIAppl_ArchiCADID
: add-on is currently running in Archicad.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h
See Also
API_ApplicationTypeID
ACAPI_GetReleaseNumber
ACAPI_Environment
API Functions