APIEnv_​CanChangePlaceSetsID

May the current user change the place settings now?

    GSErrCode ACAPI_Environment (
        APIEnv_CanChangePlaceSetsID,
        bool*                   withDialog
    );

 

Parameters

withDialog
[in] If the user don’t have permisson to change the place settings now, then the Location Dialog will open if this parameter is true, otherwise it will just return whether the user can or can not change the place settings now. This parameter is optional; if you pass nullptr, it defaults to true.

 

Return Values

NoError
The user is allowed to change the place settings.
APIERR_NOTEDITABLE
The user is not allowed to change the place settings.

For other common API errors see the API Errors document.

 

Example


        bool withDialog = false;
        ACAPI_Environment (APIEnv_CanChangePlaceSetsID, &withDialog);
        

 

Requirements

Version: API 20 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
APIEnv_ChangePlaceSetsID, APIEnv_GetPlaceSetsID, API Functions