APIEnv_​Change3DImageSetsID

Changes the 3D image item settings.

    GSErrCode ACAPI_Environment (
        APIEnv_Change3DImageSetsID,
        API_3DFilterAndCutSettings*     filterAndCutSettings,
        bool*                mustConvert
    );

 

Parameters

filterAndCutSettings
[in] Parameters of the ‘Filter and Cut Elements in 3D’ dialog box
mustConvert
[in] Optional parameter; if it is not nullptr and its value is true then the function drops the partial conversion data, so that a full rebuild will be performed upon the next Rebuild operation

 

Return Values

NoError
The function has completed with success.
APIERR_NOPLAN
No open project

 

Remarks

This function is used to change the 3D image item settings which can be accessed via the ‘Filter and Cut Elements in 3D’ dialog box.

 

Example


API_3DFilterAndCutSettings     filterAndCutSettings = {};
bool                setMustConvert;
GSErrCode           err;

err = ACAPI_Environment (APIEnv_Get3DImageSetsID, &filterAndCutSettings);
if (err == NoError) {
    filterAndCutSettings.elemTypeFilter.insert ({API_ZombieElemID, false}); // Hide everything in 3D

    ACAPI_Environment (APIEnv_Change3DImageSetsID, &filterAndCutSettings);

    filterAndCutSettings.elemTypeFilter.clear ();
    filterAndCutSettings.elemTypeFilter.insert ({API_WallID, true});
    filterAndCutSettings.elemTypeFilter.insert ({API_BeamID, true}); // show walls and beams only
    setMustConvert = true;
    ACAPI_Environment (APIEnv_Change3DImageSetsID, &filterAndCutSettings, &setMustConvert);
}

 

Requirements

Version: API 26 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment
APIEnv_Get3DImageSetsID
API_3DFilterAndCutSettings
API Functions