APIEnv_​Change3DStyleID

Modifies the parameters of an existing 3D style

    GSErrCode ACAPI_Environment (
        APIEnv_Change3DStyleID,
        API_3DStyle*     style
    );

 

Parameters

style
[in] New parameters of the existing 3D style

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
style is nullptr, or a some parameter of the style is invalid.
APIERR_NOPLAN
No open project.
APIERR_NOACCESSRIGHT
The user does not have Teamwork privilege to modify 3D styles.

For other common API errors see the API Errors document.

 

Remarks

Renaming styles is not supported, do not edit the style->name field as it is used for the identification of the existing style.

See an example at the description of APIEnv_Get3DStyleListID.

 

Requirements

Version: API 21 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API Functions,
APIEnv_Get3DStyleListID,
APIEnv_Get3DStyleID,
APIEnv_SetCurrent3DStyleID,
APIEnv_Create3DStyleID,
API_3DStyle