APIEnv_​ChangeAutoIntersectID

Modifies the automatic wall intersection flag.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeAutoIntersectID,
        bool*     isOn
    );

 

Parameters

isOn
Turns on/off the automatic wall intersection.
APIERR_NOPLAN
No open project.
APIERR_BADPARS
The isOn parameter is nullptr.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This flag was part of the Display Options in previous (pre-10) API versions. From API 10, it has started its own ‘life’.

The current state of the flag can be queried with APIEnv_IsAutoIntersectOnID.

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_IsAutoIntersectOnID, ACAPI_Environment,
API Functions