APIEnv_​ChangeCurrLayerCombID

Activates a layer combination.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeCurrLayerCombID,
        API_AttributeIndex*     layerCombIndex
    );

 

Parameters

layerCombIndex
[in] index of the layer combination to be activated

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
layerCombInd is nullptr
APIERR_BADINDEX
layerCombInd is out of range

 

Remarks

This function puts the given layer combination into effect. The currently active layer combination can be retrieved with the APIEnv_GetCurrLayerCombID environment function.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 5.2 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetCurrLayerCombID
ACAPI_Environment
API_LayerCombType
API_AttributeIndex
API Functions