APIEnv_​ChangeDocumentFrom3DDefaultsID

Changes the 3D document setting default values.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeDocumentFrom3DDefaultsID,
        API_DocumentFrom3DDefaults*     documentFrom3DDefaults
    );

 

Parameters

documentFrom3DDefaults
[in] The new default values of the 3D document database.

 

Return Values

NoError
The function completed with success.
APIERR_BADPARS
The documentFrom3DDefaults parameter is nullptr.

For other common API errors see the API Errors document.

 

Remarks

You can use this function to change the 3D document setting default values.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 12 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment, APIEnv_GetDocumentFrom3DDefaultsID, API Functions

,
API_DocumentFrom3DDefaults