APIEnv_​ChangeLayoutSetsID

Changes the settings of the current layout in Archicad.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeLayoutSetsID,
        API_LayoutInfo*       layoutInfo,
        API_DatabaseUnId*     databaseUnId
    );

 

Parameters

layoutInfo
[in] Properties of the layout.
databaseUnId 10
[in] apply changes to this database (can be nullptr). The changes are applied to the current layout or master layout database if this parameter is omitted, otherwise to the given database.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
layoutInfo is nullptr
APIERR_GENERAL
No master layout, or the function failed

For other common API errors see the API Errors document.

 

Remarks

This function is used to modify the current (master) layout parameters such as size and margin values. The size and margins are always applied to the master layout.

This function does not modify the name of the layout. This can be done with APIDb_ModifyDatabaseID database function.

The actual settings can be retrieved with the APIEnv_GetLayoutSetsID environment function.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 5.1 or later
Header: APIdefs_Environment.h

 

See Also

API_LayoutInfo
APIEnv_GetLayoutSetsID
APIEnv_GetNumberingGridLinesID
ACAPI_Environment
API Functions