APIEnv_​ChangeProjectNotesID

Changes the data of the ‘Project Info’ dialog.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeProjectNotesID,
        API_ProjectNoteInfo*     projectNoteInfo
    );

 

Parameters

projectNoteInfo
[in] project note data

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
noteInfo is nullptr
APIERR_NOPLAN
There are no project loaded.

For other common API errors see the API Errors document.

 

Remarks

This function is used to change the project info parameters. It can be set in the ‘Project Info…’ dialog box in the File/Info menu.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Example

See the example of the APIEnv_GetProjectNotesID function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_ProjectNoteInfo, APIEnv_GetProjectNotesID
ACAPI_Environment, API Functions