APIEnv_​ChangeRenderingSetsID

Changes the photorendering settings.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeRenderingSetsID,
        API_RendEffects...*     rendEffects,
        API_RendSetTypeID       rendSetType
    );

 

Parameters

rendEffects
[in] Data of a “PhotoRendering Settings…” tab page. The type depends on the prefsType parameter
rendSetType
[in] Type of the PhotoRendering Settings you want to modify

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
rendInfo is nullptr or rendSetType is invalid

For other common API errors see the API Errors document.

 

Remarks

This function is used to modify the settings of the different tab pages of the “PhotoRendering Settings…” dialog.

Usable structures of photorendering types (for rendInfo) are:

Note: the rendSetType should be passed as a value instead of a pointer; see the example below.

API 14  If you pass a valid location in the bkgPictFile pointer of the API_RendImage parameter, and the referenced file does not belong to any currently loaded library, then the image file will be copied into the embedded library of the project. This also means that any subsequent modifications to the original image file will not affect the rendering backround picture until you remove it, and add it again to the library.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Example


API_RendEffects      rendEffects;
API_RendImage        rendImage;
GSErrCode            err;

BNZeroMemory (&rendEffects, sizeof (API_RendEffects));
err = ACAPI_Environment (APIEnv_GetRenderingSetsID, &rendEffects, (void *) (Int32) APIRendSet_EffectsID);
if (err == NoError) {
    rendEffects.useBkgAlpha = true;
    err = ACAPI_Environment (APIEnv_ChangeRenderingSetsID, &rendEffects, (void *) (Int32) APIRendSet_EffectsID);
}

BNZeroMemory (&rendImage, sizeof (API_RendImage));
err = ACAPI_Environment (APIEnv_GetRenderingSetsID, &rendImage, (void *) (Int32) APIRendSet_ImageID);
if (err == NoError) {
    rendImage.bkgSkyRGB.f_red   = 0.7;
    rendImage.bkgSkyRGB.f_green = 0.5;
    rendImage.bkgSkyRGB.f_blue  = 1.0;
    err = ACAPI_Environment (APIEnv_ChangeRenderingSetsID, &rendImage, (void *) (Int32) APIRendSet_ImageID);
}
delete rendImage.bkgPictFile;

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Environment.h

 

See Also

API_RendEffects, API_RendImage, API_RendSetTypeID,
ACAPI_Environment, APIEnv_GetRenderingSetsID, APIEnv_GetRenderingSceneNamesID, APIEnv_SetCurrentRenderingSceneID, APIDo_PhotoRenderID, API Functions