APIEnv_​ChangeStorySettingsID

Modifies the story structure.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeStorySettingsID,
        API_StoryCmdType*     storyCmd
    );

 

Parameters

storyCommand
[in] Action parameters to change the story settings.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
storyCommand is nullptr or contains invalid value:
– the index is out of the range of existing stories,
– the action field is invalid.
APIERR_NOPLAN
No open project.
APIERR_MEMFULL
Low memory condition.

For other common API errors see the API Errors document.

 

Remarks

This function is used to perform story settings related commands. The command is specified by the action field of the storyCommand parameter. Possible values and the required parametrization are described at the API_StoryCmdID structure.

If this function is called with APIStory_Delete parameter, it performs complete operations. Otherwise this function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_StoryCmdID
API_StoryCmdType
APIEnv_GetGhostStorySettingsID
ACAPI_Environment
API Functions