APIEnv_​ChangeStructureDisplayID

Changes the partial structure display options for the current database.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeStructureDisplayID,
        API_UIStructureDisplay*     uiStructureDisplay
    );

 

Parameters

uiStructureDisplay
[in] The new parameters of the structure display.

 

Return Values

NoError
The function completed with success.
APIERR_NOPLAN
No plan window.
APIERR_BADPARS
The uiStructureDisplay parameter is nullptr

For other common API errors see the API Errors document.

 

Remarks

You can use this function to change the partial structure display settings.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 12 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment, APIEnv_GetStructureDisplayID, API Functions

,
API_UIStructureDisplay