APIEnv_​ChangeViewOptionsID

Changes the actual model view options.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeViewOptionsID,
        API_ViewOptions*     viewOptions,
        short*               modelViewOptionAttributeIndex
    );

 

Parameters

viewOptions
[in] the settings of the ‘Model View Options’ dialog, and the View/On-Screen View Options menu.
modelViewOptionAttributeIndex 10
[in] Optional parameter; if not nullptr, then switch to the model view options attribute identified by this index.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
viewOptions is nullptr.
APIERR_NOPLAN
There is no plan window currently opened.
APIERR_BADINDEX
attrIndex is invalid.

For other common API errors see the API Errors document.

 

Remarks

This function is used to change the on-screen and model view options. The first part of the passed structure corresponds to the parameters in the ‘Model View Options’ dialog; the other fields to the elements of the View/On-Screen View Options submenu. For more information see the API_ViewOptions structure.

The actual settings can be retrieved with the APIEnv_GetViewOptionsID environment function.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

API_ViewOptions, API_ModelViewOptionsType,
APIEnv_GetViewOptionsID
ACAPI_Environment
API Functions