Checks whether the add-on can run with the current dongle.
GSErrCode ACAPI_Environment ( APIEnv_CheckDongleID, API_DongleContent* dongleContent );
Parameters
- dongleContent
- [in] the identifier of the add-on
Return Values
NoError
- The function has completed with success.
APIERR_BADID
- The dongle does not contain the add-on’s code.
For other common API errors see the API Errors document.
Remarks
This function is used to check whether the current dongle supports the running add-on. With this third-parties can use ARCHICAD’s dongle for hardware key protection.
GRAPHISOFT has discontinued supporting this feature.
Requirements
- Version: API 3.1 or later
- Header: APIdefs_Environment.h