APIEnv_​CreateCopyOfGdlUserGlobalsHandleID

Returns a copy of the current GDL globals.

    GSErrCode ACAPI_Environment (
        APIEnv_CreateCopyOfGdlUserGlobalsHandleID,
        GDL::Parameters**     userGlobals
    );

 

Parameters

param
[out] The object containing the GDL globals required by the GDL interpreter.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The userGlobals parameter is nullptr.

For other common API errors see the API Errors document.

 

Remarks

You can use this function to obtain the current GDL globals. Do not forget to destroy the returned pointer using APIEnv_DestroyCopyOfGdlUserGlobalsHandleID.

 

Requirements

Version: API 19 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
APIEnv_DestroyCopyOfGdlUserGlobalsHandleID,
API Functions