Create a new Trace (ghost) database.
GSErrCode ACAPI_Environment ( APIEnv_CreateGhostRecordID, const API_GhostRecord* ghostRecord );
Parameters
- ghostRecord
- Information describing the new Trace database.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
This function creates a new Trace record (ghost database).
This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.
Example
This example code creates a Trace record out of the ground floor plan (assuming that the floor plan window is in front).
API_GhostRecord apiGhostRecord; GSErrCode err; API_DatabaseInfo planDB; BNZeroMemory (&planDB, sizeof (API_DatabaseInfo)); ACAPI_Database (APIDb_GetCurrentDatabaseID, &planDB, nullptr); BNZeroMemory (&apiGhostRecord, sizeof (API_GhostRecord)); apiGhostRecord.parentDatabase = planDB.databaseUnId; apiGhostRecord.floor = 0; err = ACAPI_Environment (APIEnv_CreateGhostRecordID, &apiGhostRecord, nullptr);
Requirements
- Version: API 11 or later
- Header: APIdefs_Environment.h
See Also
ACAPI_Environment,
API_GhostRecord, APIEnv_DeleteGhostRecordID, APIEnv_GetGhostRecordID, API Functions