Creates a new layout.
GSErrCode ACAPI_Environment ( APIEnv_CreateLayoutID, API_LayoutInfo* layoutInfo, API_DatabaseUnId* databaseUnId, API_Guid* parent );
Parameters
- layoutInfo
- [in] properties of the layout
- databaseUnId
- [in] Database of the master layout
- parent
- [in] Optional parameter; Parent navigator item to insert below.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
layoutInfo
ordatabaseUnId
isnullptr
or invalidAPIERR_NOPLAN
- Current windows is not plan type
APIERR_REFUSEDCMD
- This function cannot be called from an opened undo session
APIERR_GENERAL
- General internal error
For other common API errors see the API Errors document.
Remarks
This function is used to create a new layout by specifying the master layout and the parent in the layout tree.
The properties of the layout can be changed with the APIEnv_ChangeLayoutSetsID environment function.
Requirements
- Version: API 24 or later
- Header: APIdefs_Environment.h
See Also
API_LayoutInfo
APIEnv_ChangeLayoutSetsID
ACAPI_Environment
API Functions