Deletes the given embedded library item (folder or library part).
GSErrCode ACAPI_Environment ( APIEnv_DeleteEmbeddedLibItemID, const IO::Location* location, bool keepGSMFile = false, bool silentMode = false );
Parameters
- location
- [in] The location of the embedded library item.
- keepGSMFile
- [in] If this parameter is true, then the operation deletes libpart only from the embedded library, but keeps the .gsm file in the filesystem. (optional parameter, by default it’s false)
- silentMode
- [in] If this parameter is true, then the missing libpart window won’t open in case of any warning. (optional parameter, by default it’s false)
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The given
loc
parameter isnullptr
. APIERR_NOTMINE
- The operation attempted to delete a library part that belongs to another user. Likely to occur in teamwork mode.
For other common API errors see the API Errors document.
Remarks
This operation is not undoable.
Requirements
- Version: API 21 or later
- Header: APIdefs_Environment.h