APIEnv_​Get3DCuttingPlanesID

Retrieves the 3D cutting plane settings.

    GSErrCode ACAPI_Environment (
        APIEnv_Get3DCuttingPlanesID,
        API_3DCutPlanesInfo*     cutInfo
    );

 

Parameters

cutInfo
[out] Data of the “3D Cutting Planes…” dialog

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
cutInfo is nullptr
APIERR_NOPLAN
No open project
APIERR_MEMFULL
Low memory condition

 

Remarks

This function is used to get information on 3D cutting planes.

 

Example

See the example of APIEnv_Change3DCuttingPlanesID function.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Environment.h

 

See Also

API_3DCutPlanesInfo
APIEnv_Change3DCuttingPlanesID
ACAPI_Environment
API Functions