Returns the 3D image item settings.
GSErrCode ACAPI_Environment ( APIEnv_Get3DImageSetsID, API_3DFilterAndCutSettings* filterAndCutSettings );
Parameters
- filterAndCutSettings
- [out] Parameters of the ‘Filter and Cut Elements in 3D’ dialog box
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
filterAndCutSettings
isnullptr
APIERR_NOPLAN
- No open project
Remarks
This function is used to retrieve the 3D image item settings which can be accessed via the ‘Filter and Cut Elements in 3D’ dialog box. See an example at the description of APIEnv_Change3DImageSetsID.
Requirements
- Version: API 3.1 or later
- Header: APIdefs_Environment.h
See Also
ACAPI_Environment
APIEnv_Change3DImageSetsID
API_3DFilterAndCutSettings
API Functions