Returns information on the 3D projection settings.
GSErrCode ACAPI_Environment ( APIEnv_Get3DProjectionSetsID, API_3DProjectionInfo* proj3DInfo );
Parameters
- proj3DInfo
- [out] Parameters of the ‘3D Projection Settings…’ dialog
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
proj3DInfo
isnullptr
APIERR_NOPLAN
- No open project
For other common API errors see the API Errors document.
Remarks
This function is used to get the parameters can be set in the ‘3D Projection Settings…’ dialog of Archicad.
Refer to the API_3DProjectionInfo structure to get further details.
Example
API_3DProjectionInfo proj3DInfo; GSErrCode err; BNZeroMemory (&proj3DInfo, sizeof (API_3DProjectionInfo)); err = ACAPI_Environment (APIEnv_Get3DProjectionSetsID, &proj3DInfo, nullptr);
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h
See Also
APIEnv_Change3DProjectionSetsID, API_3DProjectionInfo, ACAPI_Environment, API Functions