APIEnv_​Get3DStyleID

Retrieves all parameters of a 3D style

    GSErrCode ACAPI_Environment (
        APIEnv_Get3DStyleID,
        API_3DStyle*     style
    );

 

Parameters

style
[in/out] Parameters of the 3D Style

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
style is nullptr, or style->name is invalid.
APIERR_NOPLAN
No open project.

For other common API errors see the API Errors document.

 

Remarks

Set the style->name field to the name of a valid style in the project, and call APIEnv_Get3DStyleID to get the details of that style. Leaving the style->name field empty is equivalent to setting it to the name of the current style.

See an example at the description of APIEnv_Get3DStyleListID.

 

Requirements

Version: API 21 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API Functions,
APIEnv_Get3DStyleListID,
APIEnv_Change3DStyleID,
APIEnv_SetCurrent3DStyleID,
APIEnv_Create3DStyleID,
API_3DStyle