APIEnv_​Get3DWindowSetsID

Retrieves the 3D Window settings.

    GSErrCode ACAPI_Environment (
        APIEnv_Get3DWindowSetsID,
        API_3DWindowInfo*     windowInfo
    );

 

Parameters

windowInfo
[out] Parameters of the 3D Window

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
windowInfo is nullptr
APIERR_NOPLAN
No open project

 

Remarks

This function is used to get the data of the ‘3D Window Settings’ dialog box, and the size and zoom parameters of the 3D window.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Environment.h

 

See Also

API_3DWindowInfo
APIEnv_Change3DWindowSetsID
ACAPI_Environment
API Functions