APIEnv_​GetCurrLayerCombID

Retrieves the index of the current layer combination.

    GSErrCode ACAPI_Environment (
        APIEnv_GetCurrLayerCombID,
        API_AttributeIndex*     layerCombIndex
    );

 

Parameters

layerCombIndex
[out] index of the layer combination currently in effect

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
layerCombInd is nullptr

 

Remarks

Use this function to retrieve the index of the layer combination currently set. If the current state of the layers does not match any layer combinations, the function returns 0 in the layerCombInd parameter.

You can set layers according to a given layer combination with the APIEnv_ChangeCurrLayerCombID environment function.

 

Requirements

Version: API 5.2 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_ChangeCurrLayerCombID
ACAPI_Environment
API_LayerCombType
API_AttributeIndex
API Functions