APIEnv_​GetDocumentFrom3DSettingsID

Returns the 3D document settings of the specified database.

    GSErrCode ACAPI_Environment (
        APIEnv_GetDocumentFrom3DSettingsID,
        API_DatabaseUnId*           databaseUnId,
        API_DocumentFrom3DType*     documentFrom3DType
    );

 

Parameters

databaseUnId
[in] The database unique ID of the 3D document database to get the parameters for.
documentFrom3DType
[out] The parameters.

 

Return Values

NoError
The function completed with success.
APIERR_BADDATABASE
The referred database is not a 3D document.
APIERR_BADPARS
The dbPars or documentFrom3DType parameter is nullptr, or the settings couldn’t be obtained.

For other common API errors see the API Errors document.

 

Remarks

You can use this function to obtain the 3D document settings of the specified database.

 

Requirements

Version: API 12 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment, APIEnv_ChangeDocumentFrom3DSettingsID, API Functions

,
API_DatabaseUnId, API_DocumentFrom3DType