APIEnv_​GetGhostRecordID

Retrieve a Trace record from the database.

    GSErrCode ACAPI_Environment (
        APIEnv_GetGhostRecordID,
        const API_DatabaseUnId*     databaseUnId,
        API_GhostRecord*            ghostRecord
    );

 

Parameters

databaseUnId
[in] Retrieve the trace record for this database (the parent database unid is given here).
ghostRecord
[out] The ghost record for that database.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

Use this function to retrieve an existing trace (ghost) record. You should pass the parent database unid here (the same database the trace record was created for).

 

Requirements

Version: API 11 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API_GhostRecord, APIEnv_CreateGhostRecordID, APIEnv_DeleteGhostRecordID API Functions