APIEnv_​GetGhostStorySettingsID

Retrieves the current ghost story settings.

    GSErrCode ACAPI_Environment (
        APIEnv_GetGhostStorySettingsID,
        API_GhostStoryType*     ghostStoryType
    );

 

Parameters

ghostStoryType
The ghost story settings

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
ghostStory is nullptr
APIERR_NOPLAN
There is no floor plan window opened

 

Remarks

Use this function to retrieve the ghost story settings. The same data can also be required with the APIEnv_GetStorySettingsID environment function.

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

API_GhostStoryType
APIEnv_GetStorySettingsID
APIEnv_ChangeStorySettingsID
ACAPI_Environment
API Functions