APIEnv_​GetLayoutSetsID

Returns the settings of a layout.

    GSErrCode ACAPI_Environment (
        APIEnv_GetLayoutSetsID,
        API_LayoutInfo*       layoutInfo,
        API_DatabaseUnId*     databaseUnId,
        ULong*                actualPageIndex
    );

 

Parameters

layoutInfo
[out] properties of the layout
databaseUnId Featuring API 10
[in] Optional parameter; return the layout information for this database. If nullptr, then the current layout is used.
actualPageIndex
[in] Optional parameter; return the layout information for this page.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
layoutInfo is nullptr
APIERR_BADDATABASE
The current database is not layout type

For other common API errors see the API Errors document.

 

Remarks

This function is used to retrieve the current or the given layout’s parameters such as name, size and margin values.

The properties of the layout can be changed with the APIEnv_ChangeLayoutSetsID environment function.

 

Requirements

Version: API 5.1 or later
Header: APIdefs_Environment.h

 

See Also

API_LayoutInfo
APIEnv_ChangeLayoutSetsID
APIEnv_GetNumberingGridLinesID
ACAPI_Environment
API Functions