APIEnv_​GetLibPartLockStatusID

Returns the current lock status of the given library part.

    GSErrCode ACAPI_Environment (
        APIEnv_GetLibPartLockStatusID,
        const IO::Location*   location,
        API_LockableStatus*   status,
        IO::Location*         userCacheLibPartLocation
    );

 

Parameters

location
[in] The location of the library part.
status
[out] The Teamwork lock status of the library part.
userCacheLibPartLocation API 20
[out] Location of the server library part file in the user cache (optional parameter).

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

The possible return values are the same as in ACAPI_TeamworkControl_GetLockableStatus.

API 20 From Archicad 20 library parts from BIM server libraries can be locked and edited. When a server library part becomes editable, it is copied into a separate cache on the local machine, which is called user cache. This location can be retrieved with this function in the optional userCacheLibPartLocation parameter.

 

Requirements

Version: API 15 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API Functions