APIEnv_​GetLibPartUnIDStrID

Returns the unique ID of the library part as string.

    GSErrCode ACAPI_Environment (
        APIEnv_GetLibPartUnIDStrID,
        const IO::Location*   location,
        char*                 unIDStr
    );

 

Parameters

location
[in] The location of the library part.
unIDStr
[out] The unique ID of the library part.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

The function is used to obtain the unID (as string value) of a library part using the library part’s location. You must pass a char* buffer big enough to hold two guids in string format (see API_LibPart).

 

Requirements

Version: API 15 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API Functions