Gets miscellaneous information about plotter.
GSErrCode ACAPI_Environment ( APIEnv_GetMiscPlotterInfoID, API_MiscPlotterInfo* miscPlotterInfo );
Parameters
- miscPlotterInfo
- [out] Miscellaneous information of the selected plotter
Return Values
NoError
- The function completed with success.
APIERR_BADPARS
miscPlotterInfo
isnullptr
.
Remarks
This function is used to get name and model of selected plotter in Archicad.
Example
API_MiscPlotterInfo miscPlotterInfo; GSErrCode err; BNZeroMemory (&miscPlotterInfo, sizeof (API_MiscPlotterInfo) ); err = ACAPI_Environment (APIEnv_GetMiscPlotterInfoID, &miscPlotterInfo, nullptr);
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h