Gets miscellaneous information about current printer.
GSErrCode ACAPI_Environment ( APIEnv_GetMiscPrinterInfoID, API_MiscPrinterInfo* miscPrinterInfo );
Parameters
- miscPrinterInfo
- [out] Miscellaneous information of the selected printer
Return Values
NoError
- The function completed with success.
APIERR_BADPARS
miscPrinterInfo
isnullptr
.
Remarks
This function is used to get name and orientation of selected printer in Archicad.
Supported on Windows only.
Example
API_MiscPrinterInfo miscPrinterInfo; GSErrCode err; BNZeroMemory (&miscPrinterInfo, sizeof (API_MiscPrinterInfo) ); err = ACAPI_Environment (APIEnv_GetMiscPrinterInfoID, &miscPrinterInfo, nullptr);
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h