APIEnv_​GetNavigatorChildrenItemsID

Retrieves the child items of a navigator item.

    GSErrCode ACAPI_Environment (
        APIEnv_GetNavigatorChildrenItemsID,
        API_NavigatorItem*       item,
        API_NavigatorItem***     items
    );

 

Parameters

item
[in] The requested navigator item identified with GUID (optional you should set mapId for performance).
items
[out] Data of the navigator items

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The item or the items parameter is nullptr, or contains invalid data.
APIERR_GENERAL
No open project.

 

Remarks

This function is used to get the child items of a given item of the Project Navigator.

Do not forget to dispose the items handle if not needed any more.

 

Example

Refer to the Navigator_Test example project of the API Development Kit.

 

Requirements

Version: API 4.3 or later
Header: APIdefs_Environment.h

 

See Also

API_NavigatorItem
APIEnv_GetNavigatorItemID
APIEnv_GetNavigatorParentItemID
ACAPI_Environment
API Functions