APIEnv_​GetNumberingGridLinesID

Retrieves the lines of the grid-based drawing numbering system.

    GSErrCode ACAPI_Environment (
        APIEnv_GetNumberingGridLinesID,
        APINumberingGridLineProc*     gridLineProc
    );

 

Parameters

gridLineProc
The callback function to be called to process the lines of the drawing numbering grid.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
gridLineProc is nullptr
APIERR_BADDATABASE
The current database is not layout type

 

Remarks

Use this function to enumerate the lines of the grid if the current layout uses grid-based drawing numbering.
The user-defined callback function gridLineProc is called for each line of the grid.

 

Example

See a sample callback function at the description of APINumberingGridLineProc.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Environment.h

 

See Also

API_NumberingGridLine
APINumberingGridLineProc
APIEnv_GetLayoutSetsID
APIEnv_ChangeLayoutSetsID
ACAPI_Environment
API Functions