APIEnv_​GetPlaceSetsID

Returns information on location parameters.

    GSErrCode ACAPI_Environment (
        APIEnv_GetPlaceSetsID,
        API_PlaceInfo*     placeInfo
    );

 

Parameters

placeInfo
[out] Parameters of the place.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
placeInfo is nullptr.
APIERR_NOPLAN
No open project.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the current place, date, time, and sun information. These data can be set in the Sun Settings dialog.

Refer to the APIAny_CalcSunOnPlaceID function to calculate the sun parameters on a custom place and date; Refer to the APIEnv_ChangePlaceSetsID function to set the current settings.

 

Example


API_PlaceInfo  placeInfo = {};
GSErrCode      err;

err = ACAPI_Environment (APIEnv_GetPlaceSetsID, &placeInfo, nullptr);
   

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_PlaceInfo,
ACAPI_Environment, API Functions