APIEnv_​GetProjectNotesID

Returns information about the ‘Project Info’ dialog.

    GSErrCode ACAPI_Environment (
        APIEnv_GetProjectNotesID,
        API_ProjectNoteInfo*     projectNoteInfo
    );

 

Parameters

projectNoteInfo
[out] project note data

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
projectNoteInfo is nullptr
APIERR_NOPLAN
There are no project loaded.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the project info parameters. It can be set in the ‘Project Info…’ dialog box in the File/Info menu.

 

Example


API_ProjectNoteInfo  noteInfo;

ACAPI_Environment (APIEnv_GetProjectNotesID, &noteInfo, nullptr);
CHCopyC ("John Miller", noteInfo.client);
ACAPI_Environment (APIEnv_ChangeProjectNotesID, &noteInfo, nullptr);

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_ProjectNoteInfo, APIEnv_ChangeProjectNotesID
ACAPI_Environment, API Functions