APIEnv_​GetRenderingSceneNamesID

Returns the names of all the named Rendering Scenes.

    GSErrCode ACAPI_Environment (
        APIEnv_GetRenderingSceneNamesID,
        GS::Array<GS::UniString>*    sceneNames
    );

 

Parameters

sceneNames
[out] Array of the names of all the named Rendering Scenes.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
sceneNames is nullptr.

For other common API errors see the API Errors document.

 

Remarks

The names are returned in the order of recent usage, putting the most recent rendering scene first.

 

Requirements

Version: API 18 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment, APIEnv_GetRenderingSetsID, APIEnv_ChangeRenderingSetsID, APIEnv_SetCurrentRenderingSceneID, APIDo_PhotoRenderID, API Functions