APIEnv_​GetRenderingSetsID

Returns information on the photorendering settings.

    GSErrCode ACAPI_Environment (
        APIEnv_GetRenderingSetsID,
        API_RendEffects...*     rendInfo,
        API_RendSetTypeID       rendSetType,
        const GS::UniString*    sceneName
    );

 

Parameters

rendInfo
[out] Data of a “PhotoRendering Settings…” tab page. The type depends on the prefsType parameter
rendSetType
[in] Type of the PhotoRendering Settings you want to get
sceneName API version 18
[in] The name of the Rendering Scene of which the settings you want to get. If nullptr, the settings of the current Scene will be returned.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
rendInfo is nullptr or rendSetType is invalid
APIERR_BADNAME
The sceneName parameter was not nullptr, and no named Rendering Scene exists with this name.

For other common API errors see the API Errors document.

 

Remarks

Many switches and values are returned which can be set in the different tab pages of the “PhotoRendering Settings…” dialog.

Usable structures of photorendering types (for rendInfo) are:

Note: the rendSetType should be passed as a value instead of a pointer.

Note: when you get an API_RendImage with this function, don’t forget to free the allocated memory: delete rendInfo.bkgPictFile;.

See an example of getting and modifying photorendering settings at the description of APIEnv_ChangeRenderingSetsID.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_RendEffects, API_RendImage, API_RendSetTypeID,
ACAPI_Environment, APIEnv_ChangeRenderingSetsID, APIEnv_GetRenderingSceneNamesID, APIEnv_SetCurrentRenderingSceneID, APIDo_PhotoRenderID, API Functions