Returns the location of special folders.
GSErrCode ACAPI_Environment ( APIEnv_GetSpecFolderID, API_SpecFolderID* specFolderID, IO::Location* location );
Parameters
- specFolderID
- [in] A pointer to the type of the folder you are interested in.
- location
- [out] The file system location of the required folder.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
specFolderID
contains invalid data, or thelocation
parameter isnullptr
APIERR_REFUSEDPAR
- The requested special folder is not initialized or missing
For other common API errors see the API Errors document.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Environment.h