APIEnv_​GetStorySettingsID

Returns the data of the installed stories.

    GSErrCode ACAPI_Environment (
        APIEnv_GetStorySettingsID,
        API_StoryInfo*     storyInfo,
        UInt32             mask
    );

 

Parameters

storyInfo
[out] parameters of the actual stories.
mask
Can be APIElemMask_FromFloorplan or nullptr.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
storyInfo is nullptr.
APIERR_NOPLAN
No open project.
APIERR_MEMFULL
Low memory condition.

For other common API errors see the API Errors document.

 

Remarks

The API_StoryInfo structure contains an array of information to each story (index, level, and name); and also the active one.

Do not forget to dispose the data handle if it is not needed any more.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_StoryInfo
APIEnv_ChangeStorySettingsID
APIEnv_GetGhostStorySettingsID
ACAPI_Environment
API Functions