APIEnv_​GetStructureDisplayID

Changes the partial structure display options for the current database.

    GSErrCode ACAPI_Environment (
        APIEnv_GetStructureDisplayID,
        API_UIStructureDisplay*     uiStructureDisplay
    );

 

Parameters

uiStructureDisplay
[out] The settings of the structure display in the current database.

 

Return Values

NoError
The function completed with success.
APIERR_NOPLAN
No plan window.
APIERR_BADDATABASE
The current database doesn’t have structure display settings.
APIERR_BADPARS
The uiStructureDisplay parameter is nullptr

For other common API errors see the API Errors document.

 

Remarks

You can use this function to get the partial structure display settings for the current database.

 

Requirements

Version: API 12 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment, APIEnv_ChangeStructureDisplayID, API Functions

,
API_UIStructureDisplay