APIEnv_​GetSunSetsID

Returns information on sun parameters.

    GSErrCode ACAPI_Environment (
        APIEnv_GetSunSetsID,
        API_SunInfo*     sunInfo
    );

 

Parameters

sunInfo
[out] Parameters of the sun.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
sunInfo is nullptr.
APIERR_NOPLAN
No open project.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get information on sunlight parameters. These parameters are sophisticated sunlight for photorendering.

 

Example


API_SunInfo  sunInfo = {};
GSErrCode    err;

err = ACAPI_Environment (APIEnv_GetSunSetsID, &sunInfo, nullptr);

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_SunInfo,
ACAPI_Environment, API Functions