APIEnv_​GetTWAccessRightID

Returns if the current user has the specifed access right.

    GSErrCode ACAPI_Environment (
        APIEnv_GetTWAccessRightID,
        API_TWAccessRights     accessRight,
        bool*                  hasRight
    );

 

Parameters

accessRight
[in] The access right to check.
hasRight
[out] The status of the access right in question.

 

Return Values

NoError
The function completed with success.
APIERR_BADPARS
hasRight is nullptr

For other common API errors see the API Errors document.

 

Remarks

In non-teamwork mode hasRight is always true.

You can use this function to check the user’s permissions.

 

Requirements

Version: API 14 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment
Teamwork Control
API Functions