APIEnv_​GetViewOptionsID

Returns the actual view display options.

    GSErrCode ACAPI_Environment (
        APIEnv_GetViewOptionsID,
        API_ViewOptions*     viewOptions,
        short*               attrIndex
    );

 

Parameters

viewOptions
[out] actual settings of the ‘Model View Options’ dialog, and the View/On-Screen View Options menu.
attrIndex
[out] Optional parameter; the index of the current model view options combination.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
viewOptions is nullptr
APIERR_NOPLAN
There is no plan window currently opened

For other common API errors see the API Errors document.

 

Remarks

This function is used to retrieve the actual model and on-screen view options. The returned structure corresponds to the parameters can be set in the ‘Model View Options’ dialog, and in the View/On-Screen View Options submenu. For more information see the API_ViewOptions structure.

The settings can be changed with the APIEnv_ChangeViewOptionsID environment function.

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

API_ViewOptions, API_ModelViewOptionsType,
APIEnv_ChangeViewOptionsID
ACAPI_Environment
API Functions