Returns if applicaton is in beam editing mode.
GSErrCode ACAPI_Environment ( APIEnv_IsInBeamEditModeID, bool* isInEditMode, API_Guid* editedBeam );
Parameters
- isInEditMode
- [out] Is the application in beam editing mode?
- editedBeam
- [out] (optional) The GUID of the currently edited beam.
Return Values
NoError
- The function completed with success.
APIERR_BADPARS
isInEditMode
is nullptr
For other common API errors see the API Errors document.
Remarks
You can use this function to check the state of the applicaton; many things work differently in beam editing mode.
Requirements
- Version: API 23 or later
- Header: APIdefs_Environment.h