APIEnv_​IsInStairEditModeID

Tells if Archicad is in Stair Editing mode.

    GSErrCode ACAPI_Environment (
        APIEnv_IsInStairEditModeID,
        bool*         isInEditMode,
        API_Guid*     editedStair
    );

 

Parameters

isInEditMode
[out] true if Archicad is in Stair Edit mode, false otherwise.
editedStair
The GUID of the stair being edited.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 21 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API Functions