Returns the lock state of the Survey Point.
GSErrCode ACAPI_Environment ( APIEnv_IsSurveyPointLockedID, bool* isSurveyPointLocked );
Parameters
- bool
- [out] Lock state of the Survey Point
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The passed parameter is
nullptr
Remarks
The Survey Point can be locked in order to prevent its floor plan position coordinates and the project north angle from being changed.
Example
bool isSurveyPointLocked = false; ACAPI_Environment (APIEnv_IsSurveyPointLockedID, &isSurveyPointLocked);
Requirements
- Version: API 25 or later
- Header: APIdefs_Environment.h
See Also
APIEnv_SetSurveyPointLockedID
API_GeoLocation
APIEnv_SetGeoLocationID
ACAPI_Environment
API Functions