APIEnv_​IsSuspendGroupOnID

Returns the current state of the Suspend Groups mode.

    GSErrCode ACAPI_Environment (
        APIEnv_IsSuspendGroupOnID,
        bool*     suspGrp
    );

 

Parameters

suspGrp
[out] Suspend Groups mode is ON or OFF.

 

Return Values

NoError
The function has completed with success.
APIERR_NOPLAN
There is no plan window currently opened
APIERR_BADPARS
suspGrp is nullptr

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the current suspendgroup mode. For changing the suspension state of groups use the ACAPI_Element_Tool function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Element_Tool,
ACAPI_Environment, API Functions